• Problèmes dans les liens Ekla de l'image d'origine, puis sur les titres de l'article


    Vendredi 16 Août à 19:37
    imagesdupaysdesours

    Bonsoir, lorsqu'on poste plusieurs images dans un article, parfois le lien sur une des images qui permet de l'ouvrir dans une nouvelle page (ou non) en format d'origine, disparaît (pareil sur mes deux PC ..., tous deux avec Chrome).

    J'ai trouvé l'astuce, je copie le lien de l'image réduite au format affiché sur la page ex : http://ekladata.com/9csa6O3jtXbWXagmGb49cHWjD_k@800x457.jpg et je supprime @800x457 et donc je recrée le lien disparu http://ekladata.com/9csa6O3jtXbWXagmGb49cHWjD_k.jpg

    Mais, car il y a un mais, et là j'ai mis longtemps avant de trouver d'où ça venait, je me suis aperçu que sur des articles, son titre se modifiait ! A l'instant je viens de voir que ça venait suite à ma manip. Ce titre a, incorporé : data:text etc.... (voir ci-dessous)

     Avez-vous déjà entendu parler de ces problèmes ? Merci par avance.

    Samedi 17 Août à 19:48
    Colette95

    Bonsoir,

    Une idée comme une autre... Ce problème n'est peut-être pas dû à la manipulation que tu fais pour tes images mais au fait que tu utilises l'attribut "alt" pour mettre de longs résumés sur celles-ci alors que ce dernier doit contenir uniquement et succinctement des mots clés en rapport avec lesdites images.

    De plus, il ne doit pas comporter de "_" , majuscules ni caractères accentués.

    Exemple pris sur une de tes photos :
    "Au bord de la rivière Qinnguata Kuussua : le second terrain de golf le plus septentrional du monde, mais probablement le plus étonnant ! - Kangerlussuaq - Groenland"

    Un lien à lire :
    https://optimiz.me/attribut-alt-le-alt-image/

    A part ça ?... sarcastic

    Cordialement.

    Samedi 17 Août à 20:53
    imagesdupaysdesours

    Merci mais je ne comprends rien, je ne sais même pas ce qu'est ce "alt".

    Je n'écris rien sur les images, le texte du titre s'affiche automatiquement.

    De toute façon ce phénomène est relativement récent, 6 mois, un an peut-être, je n'avais jamais trouvé comment ça se produisait quand je le trouvais sur un titre d'article, mais là ça c'est produit pendant la rédaction, donc j'ai fait la liaison ave la manip précédente qui a suivi la disparition du lien sur la photo (quand je mets plusieurs photos sur un même article). Je vais continuer à surveiller lorsque cette disparition surviendra, et si ça se reproduit, je ferai des copies d'écran et je demanderai à EKLA s'ils peuvent résoudre le problème. Mais j'aurais aimé savoir si ça se passe pour d'autres blogueurs, mais comme cette plateforme est quasiment morte, il n'y a plus grand monde qui y poste encore. Je continue car c'est un moyen pour moi de stocker mes photos et de conserver un souvenir de mes voyages, c'est tout.

    Cordialement.

    PS : au sujet des accentuations, moi, quand je passe la souris, je lis tout correctement ...

    Re PS : j'ai essayé de télécharger un pps, pas de problème, mais illisible par Power Point, il dit qu'il y a un problème et il ne peut même pas réparer.

     

    Dimanche 18 Août à 09:01
    Colette95

    Lorsque tu mets une image sur ton blog, celle-ci doit comporter obligatoirement en langage informatique l'attribut alt="" (que l'on renseigne ou pas), qui correspond au nom de l'image et sert aussi à son référencement.

    Cela tu ne le vois pas mais tu l'introduis de cette façon.
    Ajouter une image -> Choisir un fichier -> Description courte. C'est dans cette dernière case qui renseigne cet attribut  que tu insères le résumé qui apparaît sur ton image.

    Dans l'exemple plus haut que j'avais choisi sur une de tes images tu devrais avoir par exemple en titre de photo "second terrain de golf" et tout le descriptif devrait se trouver dans le texte de ton article.

    En fin de compte tu inverses le système et je me demande si ce n'est pas cette surcharge dans cet attribut qui provoquerait le bug que tu décris (à défaut d'avoir trouvé quoi que ce soit d'autre), d'autant que tu indiques que cela se produit quand tu charges plusieurs images dans le même article.

    Lorsque cela survient, nous ne sommes pas sur ton blog pour trouver la source du problème qui peut aussi, tout simplement, être un bug passager de la plateforme.

    A toutes fins utiles, ce serait bien quand même que tu t'attardes sur le lien que je t'ai indiqué. 

    En te souhaitant une excellente journée. glasses

    Cordialement.

    Dimanche 18 Août à 10:46
    imagesdupaysdesours

    Bonjour Colette, je n'ai jamais rien renseigné dans cette case ... Je viens de regarder, pourquoi jamais fait, car avec le nombre de photos que je poste, je fais au plus simple ! Et comme ça se fait automatiquement, je ne me suis jamais posé la question. Je vais surveiller afin de voir exactement à quel moment se produit ce bogue.

    Bon dimanche et encore merci.

     

    Dimanche 18 Août à 15:57
    stormalo

    Bonjour,

    >pour imagesaupaysdesours,
    je me permet d'ajouter une petite info sur le alt=" " et le title=" " 

    Cas normal.
    Supposons vouloir afficher une simple image, non cliquable.
    L'éditeur est prévu pour l'écriture d'un code html sous cette forme
    <img src= "adresse de l'image"  alt=" texte descriptif" />

    Un code plus complet peut s'écrire en ajoutant indiquant un Titre à l'image (lequel titre s'affiche normalement au survol fixe du pointeur de la souris).
    Le code doit être modifié pour devenir  :
    <img title=" titrage affiché au survol " src= "adresse de l'image"  alt=" texte descriptif de remplacement" />
    L'éditeur de code source ne propose pas de créer une balise title="  " ., il faut donc l'ajouter manuellement


    Option possible sur Eklablog; Faire afficher au survol le contenu de alt="  " au lieu de title="  "
    Cette option est dans le menu Configuration [1]. Le contenu  de l'attribut alt="  "  correspond dans l'éditeur au champ Description de l'image.

    C'est donc un détournement de l'usage normalisé. Après validation de cette option, le contenu de alt="  " n'est donc plus nécessairement adapté à son usage initial : affichage par défaut et/ou logiciels pour malvoyants, mais reconnaissons que c'est pratique, car nous n'avons pas à éditer le code source < > et l'affichage est plus rapide lors du survol.

    A mon avis l'idéal pour une info au survol très détaillée, voire personnalisée, c'est de ne pas utiliser title="  " ou alt="  ", mais d'ajouter manuellement dans le code source un  codage qui affiche une info-bulle indépendante des attributs standards en html/css
    (voir une idée ici > http://fanstasy-graph.eklablog.net/-a27953875 ↗)

    Reste à choisir, chacun selon ses priorités.

    [1] Configuration > Avancé > Afficher la description de l'image lors du survol de la souris
    ---------------------------------------------------------------------------------------------
    @Colette95,  merci pour le lien explicatif. cool
    J'utilise souvent la recherche à partir des images sans me poser la question de pourquoi dans certains cas c'est souvent plus rapide et précis que la recherche standard.

    C'est conforme à l'adage au dicton qu'un dessin ou une image c'est mieux qu'un long discours.
    ---------------------------------------------------------------------------------------------

    Bonnes suites à vous deux




    Vous devez être membre pour poster un message.