• Résolu Inscriptions bizarres dans le code source des articles


    Jeudi 13 Février à 15:29
    leszirondelles

    Bonjour,

    En voulant modifier le contenu d'un article dans ce blog

    http://1500x772.eklablog.com/

    je me suis rendue compte que le code source html contenait des dizaines de lignes  de données qui n'avaient rien à voir avec le contenu de mon article

    Je me fais rare sur mes blogs mais je constate depuis quelques temps que j'ai beaucoup de difficultés pour ouvrir les fenêtres ou pour modifier l'apparence de mes blogs

    Je dois à plusieurs reprises réactualiser les pages  pour chaque action

    Je pensais jusqu'ici que  peut-être  cela était dû à la configuration de mon navigateur en matière de sécurité et vie privée (cookies restreints)  mais maintenant j'ai un doute ...

    Je n'ai bien sûr  pas vérifié tous les articles, il y en a trop, mais beaucoup de ceux que j'ai testés sont impactés

    voici un exemple

    Bizarrement l'apparence des articles reste inchangée malgré ces données supplémentaires

    En espérant qu'il y aura une explication simple au problème d'avance je vous remercie de votre attention

    Cordialement

     

     

     

    Jeudi 13 Février à 17:24
    Colette95

    Bonsoir,

    Difficile de voir, ton blog n'est pas en ligne ni ton exemple. sarcastic

    Vendredi 14 Février à 07:25
    Pipiou

    Bonjour,

    Effectivement, les liens que tu as mis renvoient à "blog non trouvé". Une copie d'écran ? 

    Edit 15/02 :  merci pour ton MP mais je ne suis pas une pro en "codages" :  je suis allée voir et oui, y'a largement des lignes en trop frown

    j'ai fait une copie d'écran du début (+ de 300 lignes) :
    http://ekladata.com/ih54fJR7kvCvx2fmafs0qB8lyKI/leszirondelles-lignes.jpg

    Je vois du "OfficeDocumentSettings" et du "WordDocument" : tu ne ferais pas des copiés-collés par hasard ? Si oui je te renvoie à ce sujet dans le forum Trucs et Astuces :
    http://doc.eklablog.com/copies-colles-de-textes-scripts-etc-topic198598

    Il suffit (selon moi) de nettoyer le code... et/ou refaire les articles sans passer par du copier/coller sauf via le bloc-notes

    Mais il y a bien meilleurs que moi quant à la résolution et façon de faire pour tout ce qui est codes : je leur passe le clavier, et au staff bien entendu (mais c'est le week-end :)

    @ suivre

     

    Samedi 15 Février à 10:13
    Colette95

    Coucou Pipiou, smile

    Exact, c'est bien du copié/collé à partir de Word et c'est pour cela que le blog "plante".

    La seule solution c'est de reprendre article par article pour supprimer tous les codes de Word. sarcastic

    Bonne suites.

    Samedi 15 Février à 10:19
    Pipiou

    Merci Colette95 cool

    Y'a un moyen de "cibler" le début et la fin des lignes/codes pour ne sélectionner QUE le codage "en trop" et hors EB ?

     

    Samedi 15 Février à 10:29
    Colette95

    Pour cela il faudrait avoir le codage entier d'un article. Par exemple dans la pièce jointe tout est déjà à supprimer. 

     

    Samedi 15 Février à 10:39
    Pipiou

    dans ma copie d'écran c'est que le début de 332 lignes ! 

    fichier txt déposé chez EB :

    http://ekladata.com/lVPDcOyt1SXY-nHfj7S9TGqgR2o/leszirondelles.txt

    je supprimerai tout ça et j'ajouterai un simple <p></p> en première ligne, dans le code source.

    et ce dans chaque article concerné.

    j'ai bon ?

     

    Samedi 15 Février à 10:49
    Colette95

    Non, on ne peut pas faire comme ça car si tout l'article a été configuré sur Word, les codes de celui-ci doivent être imbriqués un peu partout.

    Copie/colle le code source d'un article entier pour voir.

    Samedi 15 Février à 11:02
    Pipiou

    ha oui, je comprends.

    le blog est sous mot de passe > leszirondelles : tu permets qu'on que Colette95  (parce qu'elle résoudra le problème mieux que moi) fasse un copié-collé d'un article entier pour voir les imbrications ? 

     

    Jeudi 20 Février à 11:49
    leszirondelles

    Rappel du message précédent :

    Bonjour Colette et Pipiou

    Merci à vous deux de venir m'aider

    Désolée pour la copie d'écran, je n'ai pas osé  car comme vous avez pu le constater il y en a une sacrée tartine , merci Pipiou de l"avoir fait pour moi

    En ce qui concerne les copié-collé des images c'est catégoriquement non

    Je ne publie que des images qui m'appartiennent et pour cela je les édite directement depuis mon PC

    Je n'utilise pas non plus de codes à outrance, je maîtrise bien les CSS et je n'ai aucun problème sur mes autres blogs

    Par contre il est arrivé  en effet que pour me faciliter la vie   je reproduise depuis un word une phrase que je réitère sur plusieurs articles (Pour enregistrer les images etc...)

    Je vais donc vérifier un à un tous mes articles pour voir si cela pourrait correspondre

     

    PS Le surplus qui  certainement correspond à la phrase que je mets en tout début de certains articles sera facile à supprimer car il n'est pas imbriqué dans le reste du code source

    Complément d'information suite au message précédent :

    Je confirme donc que les anomalies dans le code html des articles étaient bien dues  au copié-collé d'une simple phrase à partir d'un word et uniquement de cette phrase

    La phrase se trouvant à chaque fois au début des articles il a été facile de supprimer les codes "parasites"

    Je suis quand même étonnée qu'une simple phrase d'une ligne ait pu engendrer une telle tartine de charabia ,  plus de 300 lignes ! c'est bien fragile tout ça...

    Je ne pouvais pas deviner mais je retiens la  leçon...

    Je remercie  Colette95 ainsi que Pipiou pour leur aide gracieuse

    Cordialement

     




    Vous devez être membre pour poster un message.