• Galerie - Les images ne chargent pas depuis l'ordi


    Mardi 15 Septembre à 17:51
    filR

    Bonjour,

    Depuis un moment déjà, j'ai des problèmes pour ajouter des images à mes galeries. Parfois ça charge mais le plus souvent, ça commence à charger mais le chargement ne va pas jusqu'au bout et la nouvelle image n'apparaît pas dans la galerie.
    La barre de progression de "chargement de l'image en cours" se fige vers le début (vers 15 %) et, au bout d'un moment, elle disparaît sans que l'image soit chargée.

    Je suis sur Mac et j'ai essayé avec Chrome, Opéra et Firefox avec le même problème…
    J'ai une connexion "rurale", c'est-à-dire très lente…

    J'ai cru un moment que le problème venait du copyright inclut dans les métadonnées de l'image (depuis Photoshop). En retirant le copyright, la photo avait fini par charger.
    Mais aujourd'hui, ça recommence alors que je n'ai pas inclus de ©.
    Deux photos seulement sur 5 sont passées alors qu'elles ont été enregistrées à la suite, avec la même taille, les mêmes paramètres jpg, le même nom incrémenté (sans accent…) et qu'elles sont dans le même dossier sur mon ordi…

    Si vous avez une idée, je suis preneur car c'est vraiment galère…


    Fil

    1. Edit : après 5 ou 6 essais, deux nouvelles images sont passées (donc, ça ne vient pas des images). La dernière ne charge toujours pas…
    2. Edit : après une vingtaine d'essais (avec fermeture et réouverture de la page) la dernière photo est passée !
      Presque 1h pour ajouter 5 photos à une galerie…
      Y'a quand même un problème…
    Mercredi 16 Septembre à 09:29
    Pipiou

    Bonjour filR,

    problème sur un blog en particulier (indique l'adresse du blog concerné ça permet de "voir" les photos concernées) ou sur tous tes blogs ?

    ça peut être un problème passager, d'autant que tu dit avoir une connexion rurale (jolie expression :) 

    peut-être voir ce sujet↗ pour passer différentes possibilités en revue.

    ou poids des photos ? voir ce sujet↗

    Premières idées, quelqu'un pour d'autres idées ?

    @ suivre 

     

    Samedi 19 Septembre à 23:01
    filR

    Merci Pipiou pour tes pistes de réflexion.

    Les photos ne sont pas très lourdes (de 146 Ko à 377 Ko chacune) mais il commence à y en avoir beaucoup dans la galerie. Je viens de charger la 101e qui est passée sans histoire.

    Pour le moment, je ne poste que dans cette galerie et sur ce blog donc je ne saurais dire si j'ai le même problème ailleurs. Voici l'adresse de la galerie en question :
    http://lesdames.eklablog.com/poulailler-gallery211010

    Bonne soirée,
    Fil

    Dimanche 20 Septembre à 10:10
    Pipiou

    Effectivement, une galerie-photo de + de 100 photos, c'est plus une galerie, c'est une mine (d'exploration)  he

    Il y a eu quelques problèmes d'images il y a pas longtemps : vu le nombre de photos sur ta page, + la connexion rurale, tu as peut-être eu les prémisses du blocage ?  

    Suis allée voir le lien : super sympa le poulailler  cool 
    (je voulais mettre un commentaire mais apparemment c'est une "page simple" > pas de commentaires possibles.)

    Bonnes suites

    quelqu'un pour une autre idée ?

     

    Lundi 21 Septembre à 15:57
    filR

    Bah oui, sur les galeries, on ne peut pas commenter. Je suis le premier à le regretter.

    S'il existe une solution (à part mettre un lien vers un livre d'or ou un article "boîte aux lettres"), je suis preneur car j'ai la même restriction sur mes autres blogs :
    http://atelier-2-filr.eklablog.com/nartur-elle-p2857162 (page simple)
    et http://rgraphism.eklablog.com/technique-scientifique-gallery50170 (galerie avec lien vers une page "commentaires"… pas très satisfaisant mais mieux que rien).

    Merci pour le compliment, en tout cas :)

    Tu penses que ça pourrait donc venir du nombre de photos ?
    Je suis encore loin de la fin de ce chantier (et de la galerie). Me conseilles-tu de faire un lien vers une nouvelle galerie pour la suite des photos ? (j'aime les mines d'exploration wink2 ).

    Fil

    Lundi 21 Septembre à 17:40
    stormalo

    @filR,

    Pour rassurer sur l'aspect nombre, je connais une galerie qui a 160 photos.

    /!\  Dans une galerie de poulailler il ne faut pas mettre de photos de renard.he

    Edit: plutôt que de mettre un livre d'or comme réceptacle à commentaires, je choisirais personnellement de créer une rubrique d'articles à cet effet.

    • Chaque article serait affecté à une galerie (avec lien de retour à la galerie). Tout ça pour simplifier l'accès dans Gérer les rubriques.
    • Chaque commentaire serait gérable comme ceux des articles (avec réponse possible sous le commentaire)

    Bien sûr, ce n'est qu'un choix personnel.

    Mercredi 23 Septembre à 14:47
    filR

    Merci stormalo,

    Pas un pb de nombre alors…

    Le loquet de la porte de la basse-cour ressemble à un renard mais je n'ai pas mis la photo dans la galerie wink2

    Pas mal, la rubrique d'articles pour les commentaires mais, dans ce cas là (chantiers), ce n'est pas possible car les pages chantiers n'apparaissent pas dans mon blog (volontairement). Ces pages sont réservées aux personnes qui viennent m'aider.

    ::::::::::::
    Pour revenir au problème de chargement d'images :

    Je viens d'écrire un court article sur un de mes autres blogs. Donc, cette fois, ce n'est pas une galerie.
    La première image est passée sans problème mais impossible de charger ni la 2e ni la 3e.
    J'ai fait une vidéo écran pour montrer ce qui se passe. Comme il semble que je ne puisse pas l'insérer dans ce com, j'ai voulu la charger en tant que document sur une page du blog en question mais je rencontre exactement le même problème qu'avec les images !
    Voici donc le lien sur YT :

    https://youtu.be/NbhCEvKAPfo

    @+, Fil

     

    Edit 1 : Rien à faire pour mettre ces fichues images dans mon article.

    • Alors, je suis allé dans la Médiathèque (Gérer les documents) et j'ai créé un nouveau dossier. Dans ce dossier, mes images se chargent rapidement et sans problème !!!
      Je retourne dans mon article et au lieu de charger l'image depuis mon bureau, je colle le lien vers l'image. C'est beaucoup plus laborieux mais ça marche. Sauf que je n'ai plus accès à l'ouverture de l'image en plein écran quand on clique sur la vignette insérée dans l'article… Grrr
    • En fait, ça fait un bon moment que j'ai le problème. Depuis, je pense que Eklablog nous signale (trop souvent mais pas toujours) que des cookies vont être installés… Depuis ce changement, j'avais aussi des difficultés pour lire les statistiques mais ça semble fonctionner à nouveau correctement.

    Edit 2 : J'ai peut-être trouvé, sinon la cause, du moins une solution…

    • Sur Firefox, j'ai vidé le cache du navigateur et les images sont toutes passées pour l'article. Il faudra que je teste sur la galerie et sur mes autres navigateurs mais on est peut-être pas loin de l'épilogue (j'espère…)
    Mercredi 23 Septembre à 21:43
    stormalo

    Bonsoir filR,

    Rubriques d'articles : on peut en mettre autant que l'on veut. Celle(s) du chantier avec un mot de passe, pour les personnes qui viennent aider, et une autre sans mot de passe, pour le recueil des commentaires des galeries d'images ou des éventuelles pages simples.

    Remarque sur la photo de la médiathèque, mise dans un article et affichée en petite taille : pour la visualiser en grand suite à un clic il suffit de lui attribuer un lien qui cible son adresse de taille normale

    Inconvénient: elle s'affiche à la place de l'article au lieu d'en dessus et il faut faire "page précédente" pour revenir à l'article
    Avantage: elle s'affichera généralement beaucoup plus grande que si elle apparaissait au-dessus de l'article comme c'est la cas quand elle est mise en place depuis l'ordinateur

    Jeudi 24 Septembre à 16:08
    filR

    Merci stormalo,

    Pour les commentaires, oui, les mots de passe sont une solution. Je vais réfléchir à ça :)

    Pour l'agrandissement des images, effectivement, c'est une solution mais je préfère ouvrir une nouvelle fenêtre car c'est plus simple pour le visiteur de la fermer que de revenir à la page précédente. Pour la différence de taille, je ne savais pas que la fenêtre survolante limitait la taille. C'est intéressant. Tu connais cette limite ?

     

    Edit :

    • Bon, le coup du cache, ça a fonctionné hier mais ça ne marche plus aujourd'hui. Donc, ça vient pas de là… GRRRR, fait …
    Vendredi 25 Septembre à 08:45
    Pipiou

    Coucou,

    pour info un simple "Echap" referme une image affichée sur (par-dessus) un article. 
    Ouvrir en nouvelle fenêtre évite de perdre l'article de vue wink2 mais quand beaucoup d'images, ça peut faire beaucoup de fenêtres... 

    Pour la limitation taille, je dirais qu'une image qui s'ouvre en "nouvelle fenêtre" utilise la place disponible... sur la nouvelle fenêtre : c'est ça stormalo ? 

    Et pour le chargement irrégulier des images, à part des ralentissements de réseaux (EB et/ou FAI), je vois pas.

     




    Vous devez être membre pour poster un message.