• Résolu bug affichage image redimensionnée


    Vendredi 4 Octobre à 22:43
    NicoSite

    Bonjour

    J'ai remarqué que plusieurs images que j'ai redimensionné dans l'éditeur ne s'affichent pas sur mon blog

    par exemple ici http://www.nicosite.net/gobelins-pyrats-a107990014

    si j'affiche l'url de l'image j'ai ça

    http://ekladata.com/WSqG487qrEaDFBW9WVQDmV2kb0g@100x100.jpg

    avec le messsage

    Error:
    overload

    si j'enlève le redimensionnement de l'image @100x100 sur l'url  cela fonctionne pourtant

    http://ekladata.com/WSqG487qrEaDFBW9WVQDmV2kb0g.jpg

    pouvez-vous me dire pourquoi le fait de redimensionner une image bug?

    Samedi 5 Octobre à 09:11
    stormalo

    Bonjour NicoSite,

    Bizarre : A priori l'image enregistrée sur Eklablog serait déjà à la taille du redimensionnement demandé par le lien. 

    Normal ?

    Samedi 5 Octobre à 10:04
    NicoSite

    Bonjour Stormalo

    ici l'image originale mesure 163*163 et moi je lui demande de s'afficher en 100*100

    d'habitude cela marche et le redimensionnement fonctionne bien mais là si tu demande à afficher l'image dans ton navigateur voilà ce qui s'affiche

    Error:
    overload

    même souci avec d'autres articles comme celui-ci

    http://www.nicosite.net/gobelins-for-sock-s-sake-a107989474

    Samedi 5 Octobre à 11:20
    Colette95

    Bonjour Nico, bonjour stormalo.

    Effectivement le redimensionnement 100x100 fait disparaître l'image, je ne comprends pas pourquoi, peut-être une dimension non standard dans le codage puisque les autres passent très bien.

    Maintenant tu peux contourner le problème de cette façon pour ce post : 

    Editer ton article puis supprimer dans le html ce que j'ai mis en rouge et rajouter ce qui est en bleu :

    <a style="font-weight: bold;" href="http://player.vimeo.com/video/11191780" target="_blank"><img class="polaroid" style="width: 100px; height: 100px;" src="http://ekladata.com/WSqG487qrEaDFBW9WVQDmV2kb0g@100x100.jpg" border="0" width="100" height="100" alt=""/></a>

    Maintenant si toutes les images de tes articles sont aux mêmes dimensions, pourquoi ajouter une classe alors que tu peux configurer directement celles-ci directement dans ce code :

    .article_text img {
       width: 100px;
       height: 100px;
       /* + ajout de tes codes dans img.polaroid */

    Ainsi tu n'auras plus à te soucier de la dimension de tes images lors de l'édition d'un nouvel article.

    Samedi 5 Octobre à 11:36
    NicoSite

    bonjour Colette et merci pour ta réponse

    j'ai suivi ton conseil et ajouté à ma classe img.polaroid les dimensionnements

     width: 100px;
       height: 100px;

    et en fait c'est bon c'était tout simple ! :)

    merci!

    Samedi 5 Octobre à 13:54
    stormalo

    Re bonjour,

    du coup je viens de faire un test :

    @99x99       ça passe, l'image s'affiche

    @101x101   ça passe, l'image s'affiche  

    @100x100   message Error Overloag  (ce que Google traduit par "surcharge")

    Hum . . .  @100x100  c'est ce qu'utilise Eklablog pour l'affichage de presque toutes les images de nos pseudos. Ce qui peut bien, actuellement, provoquer une surcharge de demandes.

    D'ailleurs j'ai remarqué que nos pseudos dans les commentaires semblent parfois subir le même non affichage et je me demandais pourquoi. La réponse est peut être trouvée. 

    Bon w.e.

     

    Samedi 5 Octobre à 13:56
    NicoSite

    oui cela se tient

    à creuser du côté du staff!

    Samedi 5 Octobre à 14:01
    stormalo

    . . . d'autant que matin la taille de l'image sur mon écran était 100x100 sans le @ et  l'affichage de celle-ci dans ton post était absente, sans trace aucune ! ! ouch

    Samedi 5 Octobre à 14:05
    Colette95

    Etant curieuse et plutôt tatillon, he je suis allée fouiner dans ton css pour voir où tu avais mis les codes indiqués dans mon post précédent et y ai relevé quelques erreurs ou anomalies (au choix smile). 

    Ceux que tu as mis pour la class "polaroid"

    img.polaroid {
        opacity1.0filter:alpha(opacity100);/*inutile*/
        padding6% 6% 6%; /*manque 1 valeur -> 1 seule si les 4 identiques*/
        backgroundtransparent;
        border1px solid #9D95A5
        border-width1px 2px 2px 1px; /*pas logique dans le codage*/
        width100px;
        height100px;
    }
    img:hover.polaroid {/*pas logique d'inverser le hover*/
        opacity1.0filter:alpha(opacity=90);/*inutile et pas les mêmes valeurs*/
        padding6% 6% 6%; /*inutile*/
        backgroundtransparent;
        border1px solid #993333;
        border-width1px 2px 2px 1px;/*pas logique dans le codage*/
    }

    Ceux que j'ai mis pour arriver au même résultat que celui perçu sur ton blog.

    img.polaroid {
        width100px;
        height100px;
        padding6%;
        backgroundtransparent;
        border-top1px solid #9D95A5;
        border-right2px solid #9D95A5;
        border-bottom2px solid #9D95A5;
        border-left1px solid #9D95A5;
    }
    img.polaroid:hover {
        border-top1px solid #993333;
        border-right2px solid #993333;
        border-bottom2px solid #993333;
        border-left1px solid #993333;
    }

    C'était pour information ! sarcastic

    PS Oups ! désolée stormalo et NicoSite, chacun bossait dans son coin. hebeurk

    Samedi 5 Octobre à 14:13
    NicoSite

    merci Colette j'ai modifié suivant tes recommandations ;)




    Vous devez être membre pour poster un message.