• Résolu Affichage inadapté


    Vendredi 23 Janvier 2015 à 15:23
    stormalo

    Bonjour,

    Suite à une demande de Maximum 34 et en vérifiant de mon coté avec le tag "barèges" j'ai obtenu une erreur 404 et une proposition de recherche via google (avec le graphisme du blog). J'ai donné suite pour voir.
    Depuis mon blog "atelier du chateau" s'affiche sans le style habituel, sans barre d'administration, sans modules. Tous les autres sites ou blogs s'affichent normalement, y compris mon blog test. Cette anomalie se produit uniquement avec Firefox (avec I.E. tout est normal).

    -------------------
    J'ai l'impression que Firefox reçoit maintenant la version d'Eklablog pour affichage sur tel mobile et ceci uniquement avec l'url http://atelierduchateau.eklablog.com/. Pourtant j'utilise un PC fixe.

    Voir ci-dessous les fichiers css reçus d'Eklablog

     

    Et les copies d'écran de l'affichage correspondant (haut et bas de page):

     

    la désactivation des extensions le redémarrage de Windows, une deconnexion, une reconnexion, l'effacement du cache, , ... ne changent rien.

    Rien d'anormal signalé coté protection internet (GDATA)


    Je ne comprends pas ce qui se passe

    Vendredi 23 Janvier 2015 à 18:00
    Godefroy

    Bonjour,

    De mon côté je ne vois pas de problème sur votre blog avec Chrome et Firefox.

    Vous avez ce bug sur une seule page ou sur tout le blog ? Avez-vous essayé sur un autre ordinateur ?

    Vendredi 23 Janvier 2015 à 20:47
    stormalo

    Merci Godefroy de votre regard sur cette situation.

    Je viens de trouver l'antidote sans trop comprendre ce qui c'est passé et je voudrais bien comprendre comment, en cliquant sur une proposition de Google, qui s'affiche comme une rubrique (même design), il est possible recevoir une version mobile sur un PC fixe.

    Le dysfonctionnement n'apparaissait que sur mon PC fixe, en utilisant Firefox, et uniquement avec l'url du blog .(avec I.E., sur le même ordi, aucun problème)

    L'antidote ? Retour à la situation normale en supprimant tous les cookies, ainsi que les "préférences de site".

    L'erreur 404 avec le tag "bareges" provenait d'un espace avant le "b". J'ai corrigé, ça fonctionne.

    ---------------------------------------------

    Il me semble avoir lu sur le forum un ou deux cas d'affichage de version mobile sur ordi.

    C'est surprenant de voir apparaitre la version mobile qui s'affiche sur un PC fixe , en cliquant sur le lien proposé par un service intégré au blog.

    j'aimerais si possible avoir un éclairage sur cette anomalie ou sur ce risque avant de mettre "résolu" sur ce sujet.

    Il n'y a pas urgence. Bonne soirée.

     

    Vendredi 23 Janvier 2015 à 21:00
    lulette

    Avé

    Oui, cet affichage mode "mobile" a été signalé récemment ici, et pose problème, sans qu'on comprenne bien pourquoi comment d'où :D

    Pour moi, tout est "normal" à l'atelier, Stormalo :)

    (j'en profite, mauvaise forumeuse que je suis, pour glisser que mon dernier message à propos des limitations de caractères dans les NL, à nouveau problématique, est resté sans réponses, snif)

    :)

    Vendredi 23 Janvier 2015 à 21:51
    Damien_68 Staff
    Bonsoir, D'après ce que j'ai vu, le problème se déclenche parfois suite à une mauvaise détection. La détection se fait par rapport aux informations fournies par le navigateur (en sachant que ces derniers sont capables de se faire passer pour des navigateurs mobiles avec les outils de développement intégré).
    Samedi 24 Janvier 2015 à 15:50
    stormalo

    Bonjour Damien_68,

    Merci de cette info.

    Mais j'ai constaté que c'est un cookie qui était à l'origine de la permanence de cette anomalie

    Logiquement c'est l'environnement Eklablog qui a placé ce cookie responsable de l'affichage constant en version Mobile (1 cookie est lié à 1 site si j'ai bien compris)

    Je ne suis pas convaincu que FF soit à l'origine de ce changement brutal d'affichage (d'ailleurs je n'utilisais pas les outils de développement), mais suite à un message "404" c'est un clic sur une proposition de recherche Google - avec le design du blog - qui à été le facteur déclenchant.

    Ce qui est gênant, c'est qu'il est possible que des visiteurs aient cet affichage particulier et incomplet sans le savoir.
    J'espère au moins que ce type de cookie a une courte durée de vie.

     

    Samedi 24 Janvier 2015 à 22:53
    Stéphanie Staff

    Bonjour, 

    A titre informatif, et c'est ce que je conseille aux blogueurs qui soulèvent le souci, un simple clic sur le lien " version standard" en bas du blog suffit à revenir à la normale. 

    Dimanche 25 Janvier 2015 à 09:58
    stormalo

    Bonjour Stéphanie,

    Oui ;  je considère que mon problème est résolu.

    J'envisage de mettre une info sur le blog pour instruire les visiteurs sur les problèmes d'affichages (pas que sur ce bug aléatoire).

    A première vue il ne faut pas mettre ça dans un module puisque dans mon cas ils ne s'affichaient pas. C'est déjà un enseignement happy.

    Bonne journée.

    Vendredi 13 Février 2015 à 19:12
    huguette

    bonsoir je ne permet de venir dans votre conversation vous parlé& de l'erreur 404  j'ai eu le plaisir d’être aidé par stormalo hélas cette erreur 404 ne poursuit quand j'ouvre mon blog une fois sur deux se qui fait que la plus part de mes visiteurs ne save pas venir une bête question vu que je suis nulle lol peut ton se  débarrassé de cette 404 définitivement bonne soirée à tous cordialement  Huguette

    Vendredi 13 Février 2015 à 20:30
    stormalo

    Bonsoir huguette,

    Erreur 404 signifie que le page demandée n'a pas été trouvée: Soit il y a un erreur dans l'adresse, soit cette adresse n'existe pas ou n'existe plus.

    L'adresse de ton blog   http://huguette-1944.eklablog.com/   provoque erreur 404 car ce qui est inscrit comme page d'accueil dans Configuration > Configuration générale est faux (n'existe pas ou plus, ou comporte une erreur)

    http://huguette-1944.eklablog.com/accueil-p960714

    c'est qui est en rouge qui provoque l'erreur ! 

     




    Vous devez être membre pour poster un message.